PHP is amongst the most widely used multi-paradigm programming languages. It is pretty popular because it’s free software, which you can use to build interactive websites such as community portals, e-commerce portals or e-teaching websites instead of static HTML-based sites. A PHP module must be installed on the server where a PHP-powered site is hosted so that its code can be ‘decrypted’. Since there aren’t any license fees for this sort of module and the language itself offers incalculable options for the web apps that you build, there are 100s of millions of PHP-driven sites. On top of that, there are a myriad of PHP-based scripts, which you can use for your sites without needing to possess any coding expertise. Considering the fact that there’re several versions of PHP, you need to verify whether the exact same version that you used whilst building your site is enabled on the server too.
PHP 4 and PHP 5 Support in Shared Hosting
Our shared hosting servers support different versions of PHP, which means that your websites will work without any problems no matter if your scripts are out of date. We acknowledge the fact that an old site doesn’t automatically mean an insecure one as you may have done a lot of mods to its code. That’s the reason why we support PHP 4, 5.2, 5.3, 5.4 and 5.5 and you can choose which version will be enabled for your hosting account. You can change the version with only one single mouse click in your Hepsia hosting Control Panel and the update will take effect immediately. If you wish to run both older and newer scripts, there’s even an option to use a different version of PHP for each domain of yours at the same time.
PHP 4 and PHP 5 Support in Semi-dedicated Servers
Our semi-dedicated servers support multiple versions of PHP, which goes to say that you’ll be able to use all the Internet applications that you have developed over the years. The Hepsia Control Panel, which comes bundled with each account, will permit you to set the required version with one mouse click. You can select between PHP 4, 5.2, 5.3, 5.4 and 5.5. If you would like to host multiple sites under one single account and they have distinctive requirements connected with the hosting environment, you will be able to specify a different version for each and every one of them irrespective of which version is selected for the account itself. That’s possible thanks to our custom cloud platform, which allows us to run multiple versions of PHP simultaneously. In stark contrast, most hosting companies normally offer one, maximum two versions.